Mazda CX-50 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Question really? What appears to be half halo LEDs around the headlamps do not seem to be working. Saw them glowing on a Mazda commercial so I wanted to see for myself. Going through all the different variants on the switch including on in Drive and they do not illuminate. Has anyone experienced this yet? My CX-50 is a base Turbo, not a Premium or Premium Plus. Thanks!
 

·
Registered
Joined
·
116 Posts
Question really? What appears to be half halo LEDs around the headlamps do not seem to be working. Saw them glowing on a Mazda commercial so I wanted to see for myself. Going through all the different variants on the switch including on in Drive and they do not illuminate. Has anyone experienced this yet? My CX-50 is a base Turbo, not a Premium or Premium Plus. Thanks!
Aww, I hope you find an answer soon! However I think this might be best if you posted in the general discussion thread as this one is mainly for news updates not inquiries. Also if you could take a picture of what your headlight looks like on, that might help as well so we can help identify it further on what could be the issue.
 

·
Registered
Joined
·
22 Posts
I am not sure but from what I can see online is that the ones without adaptive headlights have a chrome halo that does not light up, while the adaptive headlights have a milky plastic halo that does light up.
 

·
Registered
Joined
·
4 Posts
If you are referring to the running lights if you go into the infotainment Vehicle Settings Exterior, I believe, you can turn on or off lots of features like adaptive headlight function, auto hi to lo headlight function and running head light. you might check those functions to see if something is checked off. Just a quick check.
 
1 - 4 of 4 Posts
Top