Mazda CX-50 Forum banner
1 - 4 of 4 Posts

Registered
'23 CX-50 TPP
Joined
2 Posts
Discussion Starter · #1 ·
Wheel Tire Car Vehicle Vehicle registration plate


First post here but have been following this forum for a while now to check up on others and their CX-50.

Purchased my CX-50 in April '22 and have driven about 13k miles on it now with a couple of snow trips, some camping, but nothing even remotely harsh. I started noticing around the beginning of this year that my car was making a squeaky rotational noise from the driver front side and took it in to get looked at. After diagnostics from the service team, they said it was the driver front strut that was needed to be replaced but the car was still safe to drive in the meantime while the part was being ordered and shipped in from Chicago. I drove the car home and got it replaced about a week later but noticed that the noise was still there but just more faint this time. Took it back and it's been sitting with the dealer for about 3 weeks now and finally getting an update that the left axle (knuckle) is not being greased up as I'm loading power into my right turns and that's why it's been squeaking/rubbing so much when I drive. Dealer says that Mazda likes to log these issues to track down as it's a brand new model and the service tech mentions my car has been the first to be logged with this issue but parts aren't expected for at least 2 weeks?

Timeline: car taken April '22, 13k current miles.

January '23 - noise started occurring, dealer says car deemed safe to drive; driver front strut replaced a week later.
February '23 - noise still occurring, taken back to dealer.
Today, March 15 '23 - call dealer and find out that they're planning to replace axle but parts on backorder; car deemed safe to drive still.

Total time spent at dealer: 2 days for first visit (strut replacement), 21 days for current visit (left axle).

Anyone else having similar driving/axle issues or anyone who's able to chime in on their experiences so far?
 

Registered
Joined
72 Posts
I had a rotational clicking sound from the rear only heard at low speed..less that 10 mph, milage at 2300. But it wasn't always there and of course the dealer visit to check it was MIA. Then about a month later( milage about 3200) sound was much more consistent so back to the dealer..rear differential needed to be replaced.
Took five days and so far all is good. Only bummer is my right door got brushed scratches in a little 3 inch by 3 inch area while it was out of my hands. But car is white so nobody else notices except me馃槴
 

Registered
Joined
12 Posts
Sorry to hear of your difficulties. Please continue to keep us posted. Did your dealership provide you with a free loaner while yours was in the shop?
BTW, the color you chose for your vehicle sure looks at home in the forest. They鈥檙e such nice looking vehicles.
 

Registered
'23 CX-50 TPP
Joined
2 Posts
Discussion Starter · #4 ·
Update over the last week (03/16-03/24): I've been in a CX-5 Preferred S

Called dealer and asked for another update on 03/16 and they stated the car was safe to drive, though the repair has not been made yet and would have to be held off until the part was available (estimating late May). I told them, regardless if they deem it safe or not, if the repair was not made that I would not feel safe because the noise itself is just part of a bigger issue and I wasn't looking to drive it any further.

Back and forth talk on letting me continue to drive my loaner because "Mazda isn't structured to loan out cars for extended periods."

Tech (03/16): "let me speak to my manager," "my manager needs to call the district service rep,"
Tech (03/24): "yeah, sorry, I never updated you. I spoke to the district service rep and he said we're cool to just keep you in the loaner until that part is available."

I've requested for scanned copies of my sales contract as well as repair orders for record.
 
1 - 4 of 4 Posts
Top