Mazda CX-50 Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
55 Posts
Discussion Starter · #1 ·
It has been approximately 9 mos since deliveries began of the CX-50. By now there are certainly a number of CX-50‘s with 10k+ miles on them. I believe forum members would be interested in your positive and not so positive comments. Please provide current miles and whether you have a Turbo or non-Turbo and, if you know, manufacture month. We look forward to your reviews. Please try to provide constructive input.
 

· Registered
2023 CX-50 Turbo Premium Plus
Joined
·
34 Posts
I hit 10k last week with my Turbo Premium Plus. One thing that's bothering me lately is that the center console lids have become a little creaky-squeaky. It's the little spring mechanism at the front of the lids causing the noise. Also, I noticed that in slow stop & go traffic, the car jumps/jerks forward when giving it the minimal amount of throttle. This happens when just rolling forward at like 5mph. It doesn't behave this way above 10mph, only under 10mph. It's like the transmission engages very aggressively like it's trying to shift but then changes its "mind"? Not sure, but those are my only negative observations so far.
 

· Registered
2014 & 2019 CX-5, 2023 CX-50 TPP
Joined
·
76 Posts
Also, I noticed that in slow stop & go traffic, the car jumps/jerks forward when giving it the minimal amount of throttle.
I've seen a couple of posts on this issue. IIRC one poster took it to the dealer and they did a TCU update which fixed the problem (YMMV)
 

· Registered
16.5 CX-5 Touring/2023 CX-50 Turbo Premium
Joined
·
42 Posts
I hit 10k last week with my Turbo Premium Plus. One thing that's bothering me lately is that the center console lids have become a little creaky-squeaky. It's the little spring mechanism at the front of the lids causing the noise. Also, I noticed that in slow stop & go traffic, the car jumps/jerks forward when giving it the minimal amount of throttle. This happens when just rolling forward at like 5mph. It doesn't behave this way above 10mph, only under 10mph. It's like the transmission engages very aggressively like it's trying to shift but then changes its "mind"? Not sure, but those are my only negative observations so far.
I am having this issue as well from 5 mph in stop and go traffic. The service advisor told me it's a normal behavior that happens on the CX-5s also as the transmission decouples from the engine if I recall correctly. I don't believe them but it is a bit jerky at low speeds.
 

· Registered
2023 CX-50 Turbo Premium Plus
Joined
·
34 Posts
I am having this issue as well from 5 mph in stop and go traffic. The service advisor told me it's a normal behavior that happens on the CX-5s also as the transmission decouples from the engine if I recall correctly. I don't believe them but it is a bit jerky at low speeds.
I was told that one user on this forum updated the TCU to ver. 00010004 and it helped out with the problem. I just did the update about 30 mins ago and see that the MyMazda app performs the remote functions in about 5 secs, as compared to before where it would take up to 30 secs. I haven't driven the car yet but I will find out tomorrow and report whether the issue is fixed or not. If you need to perform the update too, reach out to ASH8.
 

· Registered
2014 & 2019 CX-5, 2023 CX-50 TPP
Joined
·
76 Posts
I was told that one user on this forum updated the TCU to ver. 00010004 and it helped out with the problem. I just did the update about 30 mins ago and see that the MyMazda app performs the remote functions in about 5 secs, as compared to before where it would take up to 30 secs. I haven't driven the car yet but I will find out tomorrow and report whether the issue is fixed or not. If you need to perform the update too, reach out to ASH8.
If that was me (in a post above) that's not what I meant... I was meaning a Transmission Control Unit update (different TCU). But in any case, I was wrong. It was actually a transmission valve repair. See here on Reddit: (12) TP trim kept jerking in bumper to bumper traffic. Dealer is keeping the car and having Mazda engineers look at it. : CX50 (reddit.com)
 

· Registered
2023 CX-50 Turbo Premium Plus
Joined
·
34 Posts

· Registered
2023 Mazda CX-50 Turbo Premium Plus
Joined
·
120 Posts
I am having this issue as well from 5 mph in stop and go traffic. The service advisor told me it's a normal behavior that happens on the CX-5s also as the transmission decouples from the engine if I recall correctly. I don't believe them but it is a bit jerky at low speeds.
All SkyActiv-Drive automatic transmissions use a feature called a "mechatronic gear" it serves to "lock" the torque converter as a direct drive transmission (above 5mph-7mph) so you get fast crisp shifting.

 

· Registered
Joined
·
29 Posts
I hit 10k last week with my Turbo Premium Plus. One thing that's bothering me lately is that the center console lids have become a little creaky-squeaky. It's the little spring mechanism at the front of the lids causing the noise. Also, I noticed that in slow stop & go traffic, the car jumps/jerks forward when giving it the minimal amount of throttle. This happens when just rolling forward at like 5mph. It doesn't behave this way above 10mph, only under 10mph. It's like the transmission engages very aggressively like it's trying to shift but then changes its "mind"? Not sure, but those are my only negative observations so far.
There is an update that fixes this problem. I went to the dealer and they flashed it. Haven’t happened since.
 

· Registered
2023 Mazda CX-50 S PFP AWD
Joined
·
4 Posts
It has been approximately 9 mos since deliveries began of the CX-50. By now there are certainly a number of CX-50‘s with 10k+ miles on them. I believe forum members would be interested in your positive and not so positive comments. Please provide current miles and whether you have a Turbo or non-Turbo and, if you know, manufacture month. We look forward to your reviews. Please try to provide constructive input.
I just hit 10k last week. PFP - No issues to report - purchased in July..not sure the build...probably June...I purchased 2 days after it was delivered.

Had the software and tcu updated From files sent by " ASH8 "
 

· Registered
Joined
·
55 Posts
Discussion Starter · #12 ·
I just hit 10k last week. PFP - No issues to report - purchased in July..not sure the build...probably June...I purchased 2 days after it was delivered.

Had the software and tcu updated From files sent by " ASH8 "
Awesome. I received mine in June built in May, same no issues to date. Did the updates change anything noticeable?
 
1 - 13 of 13 Posts
Top